Author Topic: Swintec slide out problem  (Read 2164 times)

jandi

  • Newbie
  • *
  • Posts: 13
    • View Profile
Swintec slide out problem
« on: November 03, 2018, 12:58:41 PM »
Hello all,
          We just returned from a nice long end of season trip. When we got home I started to prep the trailer ( 2014 CL-21BHS ) to go into storage for the winter, when I noticed that the inside edge of my slideout was dragging on the floor while extending out. The mechanism seems to be working fine and we had not noticed any binding or grinding or anything unusual during our trip. It now seems that it is out of level by at least 1/2 inch top to bottom. Wanted to know if anyone else has experienced this, and has any ideas / solutions. Is this a dealer only kind of repair or are there some DIY things that I could try? This seems like something that could get a bit pricey !!! Any ideas would be helpful, THANKS.

klaker

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
Re: Swintec slide out problem
« Reply #1 on: November 04, 2018, 12:05:48 PM »
When you operate the slide do you hold the button down for a few seconds after the slide is fully extended and retracted? this has to be done or the motors can get out of sync and possibly create the problem you have.

jandi

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Swintec slide out problem
« Reply #2 on: November 04, 2018, 01:05:49 PM »
klaker,
        Thanks for your reply and yes I do hold the switch for a few seconds . This seems to only apply to the issue of side to side misalignment as there are separate motors on each side. Top to bottom each motor has a direct drive shaft from the motor on top to the lower gear so they travel in unison . I don't have a clue as to what caused this or how to correct it ! Help!!!!!

klaker

  • Jr. Member
  • **
  • Posts: 78
    • View Profile
Re: Swintec slide out problem
« Reply #3 on: November 04, 2018, 08:31:02 PM »
I don't have anymore info to share, sorry. Hope you find a solution.

Gibby

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Swintec slide out problem
« Reply #4 on: November 05, 2018, 08:34:56 AM »
I had an issue with my slide in that the bottom was still sticking out when the slide was in. The process mentioned to "Sync" the system only works on the side to side alignment, the top to bottom can only be fixed by removing the slide mechanism, and replacing. This is because they are locked together by a rod. There is a "Maintenance" kit that replaces the slide "Bushings" and a few rollers, that was tried on mine but to no avail.

Mine was in the shop for months, and it took them 3 tries to fix it (final try involved a completely new mechanism). www.lci1.com might be a good place to find repair manuals so you can at least be up to speed on how it all works.

Trust me, I feel your pain.
2014 Camplite 21RBS
2014 Ford F150 FX4 3.5L V6 EcoBoost

jandi

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Swintec slide out problem
« Reply #5 on: November 05, 2018, 10:04:56 AM »
Gibby,
        Thanks for your reply, and your situation is exactly what I was afraid of !!!!  If you don't mind telling me , how much did this end up costing you? I hope I can find a service center reasonably close to me that has someone on staff who knows the system. I'll let you know. Thanks again.

Gibby

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Swintec slide out problem
« Reply #6 on: November 06, 2018, 08:34:40 AM »
Gibby,
        Thanks for your reply, and your situation is exactly what I was afraid of !!!!  If you don't mind telling me , how much did this end up costing you? I hope I can find a service center reasonably close to me that has someone on staff who knows the system. I'll let you know. Thanks again.

In the end it cost me $3,500 CDN, and some was covered by Livin' Lite for some parts, still quite pricey.

Make sure you get someone who understands the system, even though my choice was a Camplite dealer, and a Schwintek OEM provider, I seemed to understand the system as a whole better than they did.
« Last Edit: November 06, 2018, 08:36:38 AM by Gibby »
2014 Camplite 21RBS
2014 Ford F150 FX4 3.5L V6 EcoBoost

jandi

  • Newbie
  • *
  • Posts: 13
    • View Profile
Re: Swintec slide out problem
« Reply #7 on: November 09, 2018, 06:21:15 PM »
Gibby,
        I have been talking with a few service centers near me and most have not dealt with this particular problem . Even the ones who have would not even give me a " ball-park " estimate. I was able to get a manual and some good diagrams from Lippert Components and they have a tech. support line , so I am thinking of trying the repair myself. I'll let you know !!!! Depending on the weather I may not start this until spring.