Author Topic: Help troubleshooting Dometic Fridge  (Read 272 times)

FastEddieB

  • Newbie
  • *
  • Posts: 2
    • View Profile
Help troubleshooting Dometic Fridge
« on: October 24, 2022, 08:56:46 AM »
We have a 2014 21BHS. Due to circumstances beyond our control, it has sat for roughly a year, plugged into shore power. That entire time the Dometic refrigerator worked perfectly. But a few days ago we relocated it to a different part of our property to prep it for a week-long camping trip. Plugged it back in and now the fridge is not cooling. Camper seems level. Tried it on propane and I can hear the propane fire up and run, but still no cooling. Any thoughts on troubleshooting? Weíre leaving this afternoon and a working fridge would really be nice. Iím going to call around to see if any shops can fit us in this morning. Thanks in advance.

As an aside, I was a forum member a long time ago, but had not posted in ages. In the interim we moved to Lenoir City, TN. The forum did not recognize my username, FastEddieB, which I verified via an old email. Anyway, I re-registered with that name and now that weíll be camping more I plan on dropping in more often.

Merlin

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Help troubleshooting Dometic Fridge
« Reply #1 on: October 26, 2022, 09:23:57 PM »
Hi FastEddieB. Your user name would certainly be recognized over on aluminumcamperforum.com, where you were an active member and had almost 170 posts. Try your question over there if you don't get any response here. On ACF, Paul had a fridge failure and he may have some insights.

FastEddieB

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Help troubleshooting Dometic Fridge
« Reply #2 on: October 27, 2022, 07:06:22 PM »
Thanks! It has been so long, I may have forgotten which forum I was most active on. Iíll check in over there.

Iíve gotten some pretty good input via a Facebook post. Pretty sure my problem traces to some yellowish dust in a pile in a corner of the lower access panel, which Iíve been led to believe indicates a loss of some sort of coolant medium. Camping now and just using an ice chest. Not that big a deal. When we get home Iíll try to determine if itís repairable and available options if itís not.