Author Topic: Slide and Fridge won't work on 12V power? 21 BHS  (Read 461 times)

bwebster1

  • Newbie
  • *
  • Posts: 3
    • View Profile
Slide and Fridge won't work on 12V power? 21 BHS
« on: May 19, 2020, 02:48:34 PM »
Hi there, I have a 2013 Camp Lite 21 BHS. Recently I started having an annoying issue. If I'm not plugged into 220v neither my fridge or slide will work? I just recently bought a new battery and even a battery charger. The battery charger is saying the battery is completely charged. I'm thinking since the fridge and slide's power needs to be converted when not on 220V, the converter could be the issue? If I'm at the campground plugged in, I'm all good but as soon as I unplug the slide won't work and the fridge goes right off. Obviously this isn't good because the gas won't pop on for the fridge during travel and can't get the slide out once home to unpack, etc.  Any help would be greatly appreciated!

Gibby

  • Newbie
  • *
  • Posts: 26
    • View Profile
Re: Slide and Fridge won't work on 12V power? 21 BHS
« Reply #1 on: May 20, 2020, 12:12:06 PM »
220 V, what country are you in?

Anyway, for the fridge and slide all the power does is operate the converter. The slide is 12V in all cases, and the fridge does use 110 V power when plugged in (Auto mode).

Do other 12V items (Fans, lights) work when on Battery (if not, it is the connection to the battery itself, check the fuse near the battery). If they do, it is something inside the converter (fuses???)

2014 Camplite 21RBS
2014 Ford F150 FX4 3.5L V6 EcoBoost

bwebster1

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Slide and Fridge won't work on 12V power? 21 BHS
« Reply #2 on: May 25, 2020, 10:11:23 AM »
Hey Gibby,

Thanks for the reply. I didn't get an email when you responded for some reason so just now checking!

Sorry, I totally messed up on that.  I didn't mean 220v power. I was just trying to say it doesn't function when the adapter is on the power cord when plugged into normal home plug/outlet vs. using the big 30amp plug like at a campground. When I'm plugged into 30amp, everything fires up and works perfectly, but using the adapter to plug into the house or obviously being unplugged, nothing works.

Yes, the lights and fans do work on battery, just not the slide and fridge. I thought also it may be a fuse, but I checked them all and they appear to be good to go? At least none appear to be broken, burnt, etc. I guess I could replace them all as a means of elimination.  I didn't mention this before, but the converter is having a strange buzzing noise I don't believe I have noticed before?

Thanks